"Send" with new Outlook for Windows fails or opens with Outlook (classic)

The new Outlook app from Microsoft does not support the same featres that Grunt and other apps rely on.

Problem

When attempting to send a slide or PDF using Grunt's "Send" feature, the email is generated with an attachment, but the receiver does not get the email, and it does not appear in the sent folder. No error message is displayed.

Cause

Outlook (new) for Windows does not support generating emails with an attachment. Instead, Windows tries to use Outlook (classic) to handle these emails. This issue occurs with other similar add-ins as well, not just Grunt.

Solution

Until Microsoft adds support for generating emails with attachments in Outlook (new), the system defaults to using Outlook (classic). To ensure that emails are properly sent and received, you may need to enable or repair the fallback option of using Outlook (classic) when generating emails.

For Windows 10:

  1. Open Outlook (classic). It can run simultaneously with Outlook (new).
  2. Close Outlook (classic) again.
  3. Press Start or the Windows key.
  4. Open Windows Settings, and select Apps > Default apps > Choose default apps by protocol.
  5. Find the option MAILTO (URL:MailTo Protocol).
  6. If the current default handler is Outlook (new), select it, and choose Outlook (classic) as the default handler.
  7. Select the default handler again, and change it back to Outlook (new).

For Windows 11:

  1. Open Outlook (classic). It can run simultaneously with Outlook (new).
  2. Close Outlook (classic) again.
  3. Press Start or the Windows key.
  4. Open Windows Settings, and select Apps > Default apps.
  5. In the search field titled Set a default for a file type or link type, enter MAILTO, which should then display the URL:MailTo Protocol option.
  6. If the current default handler is Outlook (new), select it, and choose Outlook (classic) as the default handler.
  7. Select the default handler again, and change it back to Outlook (new).

By following these steps, new emails with attachments should open with Outlook (classic) when using Grunt to send slides. Emails without attachments will continue to open with Outlook (new).

We suggest reaching out to Microsoft to advocate for the inclusion of support for common APIs, like generating emails with attachments, in Outlook (new). Additionally, verify your eligibility for Outlook (new) support and refer to the instructions on the Microsoft website.

 Microsoft Support Page